[ 8 posts ] 
Author Message
 Post subject: Getting error in novacomd! (From USB)
PostPosted: Wed Jan 06, 2010 1:56 am 

Joined: Sun Jul 19, 2009 12:12 am
Posts: 325
I'm getting an error in my novacomd output (I want to get into my palm pre via usb + novacom):

Code:
[2010/1/5 20:42:27] novacom_usb_findandattach_thread:424: usb_handle 0x08061e70, bus 001 dev 005
[2010/1/5 20:42:27] novacom_usb_rx_thread:354: error reading packet,         retry, rc: -1, errno 9
[2010/1/5 20:42:27] novacom_usb_rx_thread:358: error reading packet, shutting down, rc: -1, errno 9


It just keeps printing that over and over! How can i fix this?

(Using openSUSE 11.2)


Top
 Profile  
 
 Post subject: Re: Getting error in novacomd! (From USB)
PostPosted: Thu Jan 14, 2010 12:35 am 
Site Admin

Joined: Thu Jul 16, 2009 4:56 am
Posts: 3615
Location: Sunnyvale
Right now, we don't support OpenSUSE. I talked to the engineers, and they don't know exactly why the problem is occurring or how to resolve it, and I don't know when we'll have time to debug this or formally support the platform, so unfortunately, I don't really have a good answer for you. sorry.

chuq

_________________
HP Palm webOS Developer Community Manager
pdc@palm.com


Top
 Profile  
 
 Post subject: Re: Getting error in novacomd! (From USB)
PostPosted: Wed Jan 20, 2010 7:55 pm 

Joined: Sun Jul 19, 2009 12:12 am
Posts: 325
webOSdev wrote:
Right now, we don't support OpenSUSE. I talked to the engineers, and they don't know exactly why the problem is occurring or how to resolve it, and I don't know when we'll have time to debug this or formally support the platform, so unfortunately, I don't really have a good answer for you. sorry.

chuq


*sigh*

OK, I'll see if running Ubuntu in virtualbox will work.

Thanks for looking at it though.


Top
 Profile  
 
 Post subject: Re: Getting error in novacomd! (From USB)
PostPosted: Thu Mar 11, 2010 3:55 pm 

Joined: Fri Jul 17, 2009 5:05 pm
Posts: 101
download ubuntu libraries from here:

http://packages.ubuntu.com/karmic/libusb-0.1-4
http://packages.ubuntu.com/karmic/libusb-1.0-0

extract with "ar -x" and extract the data.tar.gz

go to the lib dir and execute "export LD_LIBRARY_PATH=./"

then novacomd will work

_________________
My apps: http://omoco.de


Top
 Profile  
 
 Post subject: Re: Getting error in novacomd! (From USB)
PostPosted: Sun Jun 06, 2010 12:19 am 

Joined: Wed Oct 28, 2009 7:04 pm
Posts: 3
I had the same error, I'm not using ubuntu.

It works with the solution provided.

I think Palm developers should compile novacomd with static copies of libusb not dinamically for next version, so non ubuntu users don't have to do the trick.


Top
 Profile  
 
 Post subject: Re: Getting error in novacomd! (From USB)
PostPosted: Tue Jun 08, 2010 4:02 pm 

Joined: Sun Jul 19, 2009 12:12 am
Posts: 325
SebastianHa wrote:
download ubuntu libraries from here:

http://packages.ubuntu.com/karmic/libusb-0.1-4
http://packages.ubuntu.com/karmic/libusb-1.0-0

extract with "ar -x" and extract the data.tar.gz

go to the lib dir and execute "export LD_LIBRARY_PATH=./"

then novacomd will work


Thank you VERY much for the help! Just to be sure I'm doing this correctly, the steps are:

1. Download BOTH of those files "libusb-0.1-4" and "libusb-1.0-0"?
2. Extract both of them into download folder, which gives files including "data.tar.gz" for both
3. Extract the "data.tar.gz" for both
4. Go into the newly extracted folders from "data.tar.gz" and then into the "lib" sub folder and execute "export LD_LIBRARY_PATH=./" - and do this for both extracted archives

Is that correct?


Top
 Profile  
 
 Post subject: Re: Getting error in novacomd! (From USB)
PostPosted: Tue Jun 08, 2010 6:57 pm 

Joined: Sun Jul 19, 2009 12:12 am
Posts: 325
SebastianHa, it works!! Great job!


Top
 Profile  
 
 Post subject: Re: Getting error in novacomd! (From USB)
PostPosted: Wed Aug 04, 2010 2:15 pm 

Joined: Sun Jul 19, 2009 12:12 am
Posts: 325
I'm getting this error again!

I tried executing the command "export LD_LIBRARY_PATH=./" in those lib folders again but it doesn't solve the issue! Any ideas?

UPDATE: It appears the order in which you extract and do those commands matters. It MUST be this order:

1. libusb-1/lib/> export LD_LIBRARY_PATH=./
2. libusb-0-1-4/lib/> export LD_LIBRARY_PATH=./

If you do the 0-1-4 first, it won't work.


Top
 Profile  
 
Display posts from previous:  Sort by  
   [ 8 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron