[ 19 posts ] 
Author Message
 Post subject: Enable networking in the emulator?
PostPosted: Fri Mar 04, 2011 11:44 am 

Joined: Fri Mar 04, 2011 11:41 am
Posts: 2
I'm trying to customize an existing website for webOS. For this I need to access a web server inside my office (domain) network. However, I'm unable to access any website from the emulator.

Does any one have any tips on how to enable network access in the emulator?

-Thanks!


Top
 Profile  
 
 Post subject: Re: Enable networking in the emulator?
PostPosted: Fri Mar 04, 2011 1:54 pm 

Joined: Sun Sep 20, 2009 8:03 pm
Posts: 393
Location: Albany NY
If you installed Virutabox and the Palm SDK correctly, they'll have networking.

Remember that WebOS is Linux, and thus doesn't participate in "Windows networking". You may need to enter your IP addresses by hand.


Top
 Profile  
 
 Post subject: Re: Enable networking in the emulator?
PostPosted: Mon Mar 07, 2011 4:37 am 

Joined: Fri Mar 04, 2011 11:41 am
Posts: 2
Well, I followed the instructions to the letter but no luck. I've tried changing the settings to bridged, NAT etc but nothing.

Additionally, is there a way I can initiate the command line in webOS to enable DHCP?


Top
 Profile  
 
 Post subject: Re: Enable networking in the emulator?
PostPosted: Mon Mar 14, 2011 4:45 pm 

Joined: Mon Nov 01, 2010 9:44 pm
Posts: 3
I have the same problem and it is bringing my development to a slow crawl...

Please any help troubleshooting and fixing my problem?

Thanks.


Top
 Profile  
 
 Post subject: Re: Enable networking in the emulator?
PostPosted: Mon Mar 14, 2011 11:45 pm 

Joined: Sat Jul 18, 2009 5:38 am
Posts: 8
abjbhat wrote:
Well, I followed the instructions to the letter but no luck. I've tried changing the settings to bridged, NAT etc but nothing.

Additionally, is there a way I can initiate the command line in webOS to enable DHCP?


You can access a terminal for the emulator using the following command line (make sure no webOS device is connected to your machine before running this):
Code:
novacom -t open tty://


From there, you can verify/change the IP configuration by using ifconfig, dhclient, etc.


Top
 Profile  
 
 Post subject: Re: Enable networking in the emulator?
PostPosted: Tue Mar 15, 2011 8:00 pm 

Joined: Mon Nov 01, 2010 9:44 pm
Posts: 3
Discovered, for my issue, it is related to work firewall, as internal websites load.

Does anyone know how to enable a proxy for the emulator in windows?

Thanks.


Top
 Profile  
 
 Post subject: Re: Enable networking in the emulator?
PostPosted: Wed Mar 30, 2011 5:54 pm 
User avatar

Joined: Thu Jul 16, 2009 6:32 pm
Posts: 350
Location: Palm Inc., Sunnyvale, CA
We should have some good news shortly regarding proxy support in the emulator... stay tuned!


Top
 Profile  
 
 Post subject: Re: Enable networking in the emulator?
PostPosted: Tue Apr 05, 2011 7:55 am 
User avatar

Joined: Thu Jul 16, 2009 6:32 pm
Posts: 350
Location: Palm Inc., Sunnyvale, CA
If you have the 3.0b1 SDK installed, try typing the following (in a single line command) in a device shell (novaterm or putty):
Code:
luna-send -n 1 palm://com.palm.connectionmanager/configureNwProxies '{"action":"add","proxyInfo":{"proxyScope":"default","proxyServer":"web-proxy.corp.hp.com","proxyPort":8080}}'

To disable the proxy, type:
Code:
luna-send -n 1 palm://com.palm.connectionmanager/configureNwProxies '{"action":"rmv","proxyInfo":{"proxyScope":"default","proxyServer":"web-proxy.corp.hp.com","proxyPort":8080}}'


Of course, you'll want to supply your own server info in place of "proxy.corp.hp.com" unless you happen to be working on the internal HP network. :-)
--Steve


Top
 Profile  
 
 Post subject: Re: Enable networking in the emulator?
PostPosted: Wed Apr 20, 2011 6:28 pm 

Joined: Wed May 19, 2010 9:19 pm
Posts: 27
anybody know what json to add to specify a username and password?


Top
 Profile  
 
 Post subject: Re: Enable networking in the emulator?
PostPosted: Wed Jun 01, 2011 10:58 am 

Joined: Tue May 31, 2011 2:43 pm
Posts: 1
Hello guys

when I did the same thing in putty, I got following error:

{"returnValue":false,"errorCode":-1,"errorText":"Unknown method \"configureNwProxies\" for category \"/\""}

Any ideas?


Top
 Profile  
 
 Post subject: Re: Enable networking in the emulator?
PostPosted: Thu Aug 04, 2011 1:40 pm 

Joined: Wed Jun 23, 2010 1:44 pm
Posts: 16
Location: Germany
this error msg seems to come from a pre-3.x SDK emulator

Steve, any idea how to enable the proxy on webOS 1.4.5 and 2.1.x emulators?
Thx!


Top
 Profile  
 
 Post subject: Re: Enable networking in the emulator?
PostPosted: Fri Aug 05, 2011 7:32 am 
User avatar

Joined: Thu Jul 16, 2009 6:32 pm
Posts: 350
Location: Palm Inc., Sunnyvale, CA
chrisill wrote:
Steve, any idea how to enable the proxy on webOS 1.4.5 and 2.1.x emulators?

Proxy support is only supported in the 3.0 (and later) emulators since it was first added to webOS for 3.0. I will check and see if might also be available in the 2.2 (Pre3) emulator that is in early access, but I wouldn't expect to see an updated 1.4.5 or 2.1.0 image with proxy support.


Top
 Profile  
 
 Post subject: Re: Enable networking in the emulator?
PostPosted: Wed Aug 24, 2011 11:51 pm 

Joined: Wed Aug 24, 2011 11:48 pm
Posts: 1
nohorse wrote:
anybody know what json to add to specify a username and password?


I too would like to know this. I have tried for the username the following json's with no luck:

proxyUsername
proxyUserName
proxyUser
proxyAccount
poxyName


Top
 Profile  
 
 Post subject: Re: Enable networking in the emulator?
PostPosted: Mon Aug 29, 2011 6:33 pm 

Joined: Mon Aug 29, 2011 6:20 pm
Posts: 1
lemketron wrote:
If you have the 3.0b1 SDK installed, try typing the following (in a single line command) in a device shell (novaterm or putty):
Code:
luna-send -n 1 palm://com.palm.connectionmanager/configureNwProxies '{"action":"add","proxyInfo":{"proxyScope":"default","proxyServer":"web-proxy.corp.hp.com","proxyPort":8080}}'

To disable the proxy, type:
Code:
luna-send -n 1 palm://com.palm.connectionmanager/configureNwProxies '{"action":"rmv","proxyInfo":{"proxyScope":"default","proxyServer":"web-proxy.corp.hp.com","proxyPort":8080}}'


Of course, you'll want to supply your own server info in place of "proxy.corp.hp.com" unless you happen to be working on the internal HP network. :-)
--Steve


Thanks Steve! Worked great on my Touchpad using Novaterm.

However, it seems that the mail app ignores the proxy.

Any advice on making this a quick script with an icon that can be run from the Touchpad stand-alone?


Top
 Profile  
 
 Post subject: Re: Enable networking in the emulator?
PostPosted: Tue Aug 30, 2011 4:38 am 

Joined: Tue Aug 30, 2011 4:35 am
Posts: 1
lemketron wrote:
If you have the 3.0b1 SDK installed, try typing the following (in a single line command) in a device shell (novaterm or putty):
Code:
luna-send -n 1 palm://com.palm.connectionmanager/configureNwProxies '{"action":"add","proxyInfo":{"proxyScope":"default","proxyServer":"web-proxy.corp.hp.com","proxyPort":8080}}'

To disable the proxy, type:
Code:
luna-send -n 1 palm://com.palm.connectionmanager/configureNwProxies '{"action":"rmv","proxyInfo":{"proxyScope":"default","proxyServer":"web-proxy.corp.hp.com","proxyPort":8080}}'


Of course, you'll want to supply your own server info in place of "proxy.corp.hp.com" unless you happen to be working on the internal HP network. :-)
--Steve



1000x 'fuck-yes!'


Top
 Profile  
 
 Post subject: Re: Enable networking in the emulator?
PostPosted: Thu Sep 08, 2011 6:40 am 

Joined: Thu Sep 08, 2011 6:29 am
Posts: 1
gXnIcKb wrote:
lemketron wrote:
If you have the 3.0b1 SDK installed, try typing the following (in a single line command) in a device shell (novaterm or putty):
Code:
luna-send -n 1 palm://com.palm.connectionmanager/configureNwProxies '{"action":"add","proxyInfo":{"proxyScope":"default","proxyServer":"web-proxy.corp.hp.com","proxyPort":8080}}'

To disable the proxy, type:
Code:
luna-send -n 1 palm://com.palm.connectionmanager/configureNwProxies '{"action":"rmv","proxyInfo":{"proxyScope":"default","proxyServer":"web-proxy.corp.hp.com","proxyPort":8080}}'


Of course, you'll want to supply your own server info in place of "proxy.corp.hp.com" unless you happen to be working on the internal HP network. :-)
--Steve



1000x 'fuck-yes!'
Mail seems to work OK, but Apps don't seem to work at the moment.

I had to add this to get Skype to work

file : /var/skypekit/shared.xml

insert before </Connection>

<HttpsProxy>
<Addr>your-proxy:your-port</Addr>
<Enable>1</Enable>
<Pwd></Pwd>
<User></User>
</HttpsProxy>

Not sure if it will be overwritten post device restart yet. I killed the skype process after the modification, and the system restarted it no problem

A way to change the proxy (and change any other files automatically) would be brilliant !


Top
 Profile  
 
 Post subject: Re: Enable networking in the emulator?
PostPosted: Tue Sep 13, 2011 10:01 am 

Joined: Tue Sep 13, 2011 9:48 am
Posts: 1
lemketron wrote:
If you have the 3.0b1 SDK installed, try typing the following (in a single line command) in a device shell (novaterm or putty):
Code:
luna-send -n 1 palm://com.palm.connectionmanager/configureNwProxies '{"action":"add","proxyInfo":{"proxyScope":"default","proxyServer":"web-proxy.corp.hp.com","proxyPort":8080}}'
To disable the proxy, type:
Code:
luna-send -n 1 palm://com.palm.connectionmanager/configureNwProxies '{"action":"rmv","proxyInfo":{"proxyScope":"default","proxyServer":"web-proxy.corp.hp.com","proxyPort":8080}}'
Of course, you'll want to supply your own server info in place of "proxy.corp.hp.com" unless you happen to be working on the internal HP network. :-) --Steve

Help! My company has an automatic proxy configuration URL as follows:
Quote:
http://internal.mycompany.com:8080/proxy.pac
With the above instructions, I can specify:
  • "proxyServer":"internal.mycompany.com"
  • "proxyPort":8080
But how do I specify the local path "/proxy.pac" in the proxy URL?

Not this is not an issue for iOS & Android devices, but I would greatly appreciate any suggestions on getting this to work on my Touchpad.
Thank you in advance.


Top
 Profile  
 
 Post subject: Re: Enable networking in the emulator?
PostPosted: Sat Sep 24, 2011 1:28 am 

Joined: Sat Sep 24, 2011 1:09 am
Posts: 1
I wrote an app to switch proxy access on and off. In order to integrate automatic proxy scripts and proxies with authorization, I would be interested in some sort of documentation/further information about the "com.palm.connectionmanager/configureNwProxies" service.

When I package and run my app in a com.palm.* scope, the communication with the service works perfectly and the proxy server gets added. However, once I package and run my app in a more appropriate scope like com.domain.*, I receive the following error when the app communicates with the service:

{"returnValue":false,"errorCode":-1,"errorText":"Unknown method \"configureNwProxies\" for category \"/\""}

I did some more testing and I think I figured out the reason for this behaviour:

Executing:
Code:
luna-send -n 1 palm://com.palm.connectionmanager/configureNwProxies '{"action":"add","proxyInfo":{"proxyScope":"default","proxyServer":"128.0.0.1"
,"proxyPort":80}}'

Returns:
Code:
{"returnValue":true}

HOWEVER

Executing:
Code:
luna-send -n 1 -P palm://com.palm.connectionmanager/configureNwProxies '{"action":"add","proxyInfo":{"proxyScope":"default","proxyServer":"128.0.0.1"
,"proxyPort":80}}'

Returns:
Code:
{"returnValue":false,"errorCode":-1,"errorText":"Unknown method \"configureNwProxies\" for category \"/\""}

It looks as if the method "configureNwProxies" of the connectionmanager service is not exposed on the public bus. Therefore, I guess an app packaged as com.palm.* has access to the private bus, whereas apps packaged as com.somethingotherthanpalm.* only have access to the public bus.

Since I'm new to webOS development, I would be interested if there is a different way to gain access to the same method on the private bus? If not, then I would probably need to distribute the app as a homebrew app, because hp wouldn't allow me to distribute com.palm.* apps through their App Catalog. Does anybody have experience with distributing homebrew apps? How exactly would I go about that?

Cheers!


Top
 Profile  
 
 Post subject: Re: Enable networking in the emulator?
PostPosted: Wed Apr 09, 2014 9:53 am 

Joined: Wed Apr 09, 2014 9:26 am
Posts: 4
I had to add this to get Skype to work





________________
Fut 14 coins


Top
 Profile  
 
Display posts from previous:  Sort by  
   [ 19 posts ] 


Who is online

Users browsing this forum: Google [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron