[ 8 posts ] 
Author Message
 Post subject: [bug] HtmlContent rendering issue
PostPosted: Mon Sep 12, 2011 1:18 pm 

Joined: Sat Dec 19, 2009 11:44 am
Posts: 71
Location: Dundee, UK
I have an app with three sliding panes, one of which contains a HtmlContent area. It renders fine most of the time, but when I slide the panes left to close only the first one and then re-open it, the content gets badly warped.

Image

This only seems to be happening in landscape mode. Attempting to scroll the HtmlContent area, changing the orientation of the device to portrait or re-closing the left-most pane causes the content of the HtmlContent area to render properly again. Flipping the tablet over straight to the opposite landscape orientation doesn't fix the problem.

_________________
Image DnD 4e Compendium - Blog - Source


Top
 Profile  
 
 Post subject: Re: [bug] HtmlContent rendering issue
PostPosted: Tue Sep 13, 2011 5:45 pm 

Joined: Fri Jan 15, 2010 8:15 pm
Posts: 171
I believe this was one of the issues resolved in a recent internal build. If there was a way to test your app to be certain, I'd be willing to help - as I am unable to replicate the issue on my end.

_________________
Jeremy T.
HP/Palm Developer Relations


Top
 Profile  
 
 Post subject: Re: [bug] HtmlContent rendering issue
PostPosted: Tue Sep 13, 2011 5:55 pm 

Joined: Sat Sep 12, 2009 5:27 pm
Posts: 847
germboy wrote:
I believe this was one of the issues resolved in a recent internal build. If there was a way to test your app to be certain, I'd be willing to help - as I am unable to replicate the issue on my end.


Have you solved the blurry rendering too?

_________________
Newness Developments
@newnessdevs
webOS Apps: Mail Lists, Communicate


Top
 Profile  
 
 Post subject: Re: [bug] HtmlContent rendering issue
PostPosted: Tue Sep 13, 2011 9:31 pm 
User avatar

Joined: Thu Jul 16, 2009 2:37 pm
Posts: 5177
Location: HP (Palm), Austin, TX (@unwiredben on Twitter)
Blurry rendering was a WebView issue, not a HtmlContent issue. The Enyo.htmlContent kind just adds HTML into the app's DOM, and display issues like the one seen here are WebKit rendering bugs. WebView runs the content in a separate WebKit instance and the blurry rendering was due to that BrowserServer not keeping active renders of all the instances.


Top
 Profile  
 
 Post subject: Re: [bug] HtmlContent rendering issue
PostPosted: Tue Sep 13, 2011 10:36 pm 

Joined: Sat Sep 12, 2009 5:27 pm
Posts: 847
unwiredben wrote:
Blurry rendering was a WebView issue, not a HtmlContent issue. The Enyo.htmlContent kind just adds HTML into the app's DOM, and display issues like the one seen here are WebKit rendering bugs. WebView runs the content in a separate WebKit instance and the blurry rendering was due to that BrowserServer not keeping active renders of all the instances.


Ben, I'm not using webViews, but my carousel pages render blurry sometimes.

_________________
Newness Developments
@newnessdevs
webOS Apps: Mail Lists, Communicate


Top
 Profile  
 
 Post subject: Re: [bug] HtmlContent rendering issue
PostPosted: Wed Sep 14, 2011 7:34 am 

Joined: Thu Aug 25, 2011 11:26 pm
Posts: 1392
Location: Michigan
I like the sound of "was" as it is used in those statements, so long as it isn't stealing performance?


Top
 Profile  
 
 Post subject: Re: [bug] HtmlContent rendering issue
PostPosted: Wed Sep 14, 2011 9:18 am 

Joined: Sat Dec 19, 2009 11:44 am
Posts: 71
Location: Dundee, UK
unwiredben wrote:
display issues like the one seen here are WebKit rendering bugs.

Does this mean there's nothing can be done to fix it, except a WebKit update?

_________________
Image DnD 4e Compendium - Blog - Source


Top
 Profile  
 
 Post subject: Re: [bug] HtmlContent rendering issue
PostPosted: Wed Sep 14, 2011 6:13 pm 
User avatar

Joined: Thu Jul 16, 2009 11:37 pm
Posts: 190
Location: Brooklyn, NY
I've seen issues with a blurry content regarding Sliding Panes and Scrollers where there is no WebView, though its not nearly as severe as shown here.

This repros in both the device and in Chrome, though in Chrome its less blurry.

Inspection in Chrome shows a transform3d with a non-integer value - I suspect that the transform of either the scroller or the panel makes the font rendering blurry, compared to the normal crisp display.

Also seen this repro in the Email app lists occasionally. At some scroll positions the text of the list items appears to blur.

_________________
Ryan Watkins

ryan@ryanwatkins.net / @ryanwatkins
Paper Mache - http://www.ryanwatkins.net/software/papermache/


Top
 Profile  
 
Display posts from previous:  Sort by  
   [ 8 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron