[ 4 posts ] 
Author Message
 Post subject: pdk has wrong version of libSDL_ttf.so
PostPosted: Fri Jan 20, 2012 11:30 pm 

Joined: Wed Jan 11, 2012 11:49 pm
Posts: 2
I was playing around with the badfont app from the blog and tried to add an outline font. Whilst the header files support these calls, the pdk libraries for both the emulator and touchpad seem to be older versions that do not support these calls, giving a link error. If I copy these libraries off the emulator and touchpad and drop them in the appropriate directories the errors go away (just get warnings) and the modified app runs fine.

any chance of this being fixed in future releases (first noticed this on 3.0.4 and is also in 3.0.5 pdk)? Or making them available somewhere as the link warnings are a pain (makes it difficult to spot other compile / link errors)


Top
 Profile  
 
 Post subject: Re: pdk has wrong version of libSDL_ttf.so
PostPosted: Sat Jan 21, 2012 5:03 pm 
User avatar

Joined: Thu Jul 16, 2009 2:37 pm
Posts: 5177
Location: HP (Palm), Austin, TX (@unwiredben on Twitter)
Pulling them off device is the best way right now. I'll file a bug for resolving in future SDK releases.


Top
 Profile  
 
 Post subject: Re: pdk has wrong version of libSDL_ttf.so
PostPosted: Sun Jan 22, 2012 6:09 pm 

Joined: Wed Jan 11, 2012 11:49 pm
Posts: 2
thanks. I was experimenting with the badfont app because I wanted to replace the font drawing in an app I'm updating to use SDL ttf rather than the SFont it was using. I wanted to add an outline to make the text look crisper so was using TTF_SetOutlineFont().

All my testing so far has been on my touchpad. Today I thought I'd better test it for the pre, so loaded it onto a pre emulator. Unfortunately it seems to have an older version of the SDL_ttf library on it which doesn't support this call.

The touchpad has version 0.10.0, the pre emulator has version 0.6.3 (don't have access to any pre hardware so cannot confirm what that has got).

This might explain why the the pdk had the older version.

Looks like I'll need to test the ttf version before attempting to outline my text.


Top
 Profile  
 
 Post subject: Re: pdk has wrong version of libSDL_ttf.so
PostPosted: Sun Jan 22, 2012 7:17 pm 
User avatar

Joined: Thu Jul 16, 2009 2:37 pm
Posts: 5177
Location: HP (Palm), Austin, TX (@unwiredben on Twitter)
Yeah, SDL_ttf only got upgraded in webOS 3.0, so older device builds don't have outline support.


Top
 Profile  
 
Display posts from previous:  Sort by  
   [ 4 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron